当前位置: > 运维管理 > RouterOS路由系统 >

ROS常用命令大全

时间:2013-08-15 22:12来源:centoscn.com 作者:感谢:“匿名”投稿 举报 点击:

        看了很多router os 的资料都是关于如何安装的,却很少见到关于router os的命令资料(也许因为有winbox了),虽然在router os 的手册中有说明,但是是英文版本的,很不好看懂。下面就我就写出一些常用的命令,希望对大家有所帮助:

      1、开机登陆以后常用的一个 ? 是常用的帮助命令,可以列出可用的命令及简单的说明。
 
  2、有些英文命令很长,可以简写如interface ,你输入in后回车自动就会进入interface了。或者你可以按下tab键来帮你完成长英文命令的输入。
 
  3、有些命令的参数很多,你不知道的时候可以输入命令后加空格 ?,如print ?
 
  可以显示该命令的参数。
 
  4、setup 该命令可是谁都要记得的,因为最初安装完router os 必须用它分配网卡的ip地址。
 
  5、ip route add gate=211.12.*.14,220.163.*.12 该命令用于多线路接入时加入多个网关用的。
 
  6、ip firewall add action=nat protocol=tcp dst-address=212.12.*.*/32:80 to-dst-address=192.168.0.198 该命令用于映射端口80到本地的192.168.0.198上。
 
  7、print 该命令有点用于列出所有的项目。
 
  8、interface monitor-traffice 0,1,2 可以监视当前0,1,2网卡的活动情况。
 
  9、ip firewall connection print 显示当前的所有的连接。
 
  10、ip arp print 显示所有router os 知道的ip地址和mac地址的对应列表。
 
  11、user active print 显示所有的router os 的活动用户。
 
  12、system reboot 、system shutdown分别是重启和关机。
 
  13、system reset 删除所有原来的配置,并重新启动router os. 14、system resource monitor 可以监视当前的cpu,和内存的使用情况。
 
  15、log print 可以显示router os 的日志。
 
  16、tool ping-speed 210.13.14.* 可以显示ping 的速度。
 
  17、tool sniffer start,和tool sniffer stop 可以开启和停止嗅探器。
 
  18、tool sniffer packet print 可列出嗅探的包。
 
  19 、system backup name=2004107.bak 可以将系统的配置备份到文件2004107.bak,可以用file print看到。
 
  还有什么enable,disable,remove,set 那些常用的就不说了。
 
  以上是我用了router os接入两个光纤后,常使用的一些命令,发现router os 真是个好东西,所以忍不住写出来,为router os 宣传一下。有很多不成熟的东西,希望大家多原谅。
 
  /sy reset 恢复路由原始状态
 
  /sy reboot 重启路由
 
  /sy showdown 关机
 
  /sy ide set name=机器名 设置机器名
 
  /export 查看配置
 
  /ip export 查看IP配置
 
  /sy backup 回车
 
  save name=你要设置文件名 备份路由
 
  LOAD NAME=你要设置文件名 恢复备份
 
  /interface print 查看网卡状态
 
  0 X ether1 ether 1500 这个是网卡没有开启
 
  0 R ether1 ether 1500 这个是正常状态
 
  /int en 0 激活0网卡
 
  /int di 0 禁掉0网卡
 
  /ip fir con print 查看当前所有网络边接
 
  /ip service set www port=81 改变www服务端口为81
 
  /ip hotspot user add name=user1 password=1 增加用户

 

      查看内存及CUP使用情况:/ system resource monitor
 
  查看当前所有网络连接:/ ip firewall connection print
 
  重新启动路由:/ system reboot
 
  路由关机:/ system shutdown
 
  恢复默认安装:/ system reset
 
  查看系统时间:/ system clock print
 
  查看系统常规信息:/ system resource print
 
  查看PC信息:/ system resource pci print
 
  查看等级以及许可:/ system license print
 
  查看系统组件及安装包:/ system package print
 
  查看系统管理员列表:/ user print
 
  查看系统日志:/ log print
 
  查看IP配置情况:/ ip address print
 
  查看网卡情况:/ interface print
 
  查看网关情况:/ ip route print
 
  查看防火墙情况:/ ip firewall filter print

关机:system—shutdown
重启:/sy reboot
/ip add pri 查看IP配置
/sy backup
save name=保存的文件名
/int pri 查看网卡状态
import *.rsc 防火墙导入命令(前提是*.rsc已经放在了ROS的FTP中)
/ip firewall export file=*.rsc 备份防火墙

/ip fir con print
用户:lish ps:love
/ip address add address 10.0.0.1/24 interface ether1
/ip address add address 10.0.0.1 netmask 255.255.255.0 interface ether1
/set r 恢复路由初始
/sy reboot 重启路由
/sy showdown 关机
/sy ide set name=机器名 设置机器名
/export 查看配置
/ip export 查看IP配置
/sy backup 回车
save name=你要设置文件名 备份路由
LOAD NAME=你要设置文件名 恢复备份
/interface print 查看网卡状态
0 X ether1 ether 1500 这个是网卡没有开启
0 R ether1 ether 1500 这个是正常状态
/int en 0 激活0网卡
/int di 0 禁掉0网卡
/ip fir con print 查看当前所有网络边接
/ip service set www port=81 改变www服务端口为81
/ip hotspot user add name=user1 password=1 增加用户
关于如何绑定MAC和IP 来防止IP冲突 ROS和其他代理服务器一样,有个弱点,如
果内网有人把客户机IP改成 和网关相同的IP(如 192.168.0.1这样的),那么过
了一会,ROS的就失去了代理作用,整个网吧就会吊线。 用超级管理员账号登录
,IP-----ARP,这样可以看到 一行行的 IP和MAC地址,这些就是内网有网络活动
的计算机。选中一个,双击,选COPY----点OK,依次进行,全部绑定后,来到
WINBOX的INTERFACE选项,双击内网网卡,在ARP选项里,选择“replay-only”至
此,通过ROS绑定IP完毕,这样下面客户机只要一改IP,那么它就无法和网关进行
通讯了,当然也无法使主机吊线了


ROS防syn ip-firewall-connections Tracking:TCP Syn Sent Timeout:50 TCP 
syn received timeout:30


ROS端口的屏蔽 ip-firewall-Filer Rules里面选择 forward的意思代表包的转发 
firewall rule-General Dst.Address:要屏蔽的端口 Protocol:tcp 
Action:drop(丢弃)


ROS限速 Queues-Simple Queues name:可以任意 Dst. Address:内网IP/32 Limit 
At (tx/rx) :最小传输 Max Limit (tx/rx) :最大传输

如果有一些网页打不开,你ISP的MTU=1492,请在IP > 
Firewall > Mangle > 单击红加号 > Protocol选择TCP > Tcp Options 选择 
sync > Actions选择 accept >TCP MSS:1448。 ip-firewall -filter fules ,
选择 + 号,in interface 选择内网网卡(local),其他默认这条路由允许来
自内网的连接,如果有限制,可以修改 src address 的ip段,或者content 内容
过滤 ip -》firewall -》filter chains 选中 input ,选择 drop 这条规则
禁止所有的外部连接 以上两条规则,屏蔽来自外网的所有连接 一些恶意网站和
广告,也可以从这里屏蔽 关于解决不能上百度的问题记录网卡MAC地址才能限制
网卡上网。具体设置如下。在防火墙里面的filter rules项选择forward然后添加
一项设定也就是“+”号,在advanced项里面的src .mac.address项里面加入网
卡的MAC地址,然后在ACTION中选择DROP项。这样子添加后,那块网卡的ip地址无
论咋换,都无法上网。除非它把网卡换了。我就是这样子作出来得,效果不错
如果改了端口用winbox打不开了的解决方法 用SSH进入 /ip ser /ip ser/>set 
www port 80 /ip ser/>set ftp port 21

发表评论
为了和诣的生活,我关闭了评论页面,请大家到QQ群里交流吧:348944156,也欢迎关注本站微信公众号:centoscn