当前位置: > 故障解决 > 常用软件问题 >

pip安装matplotlib报错:equired packages can not be built

时间:2016-06-08 01:28来源:blog.csdn.net 作者:AndersJing 举报 点击:

pip安装matplotlib

在centos6.5 64bit上用pip安装matplotlib时候报错:

* The following required packages can not be built:
                        * freetype, png
error: Setup script exited with 1

这是因为pip不能安装操作系统的依赖库导致的,需要用yum手动安装:

$ yum -y install freetype-devel libpng-devel

如果不知道这些库需要安装的包名,可以查一下:

$ yum search freetype | grep devel
    freetype-devel.i686 : FreeType development libraries and header files
    freetype-devel.x86_64 : FreeType development libraries and header files
$ yum search png | grep devel
    libpng-devel.i686 : Development tools for programs to manipulate PNG image
    libpng-devel.x86_64 : Development tools for programs to manipulate PNG image

参考:  http://stackoverflow.com/questions/20533426/ubuntu-running-pip-install-gives-error-the-following-required-packages-can-no

发表评论
为了和诣的生活,我关闭了评论页面,请大家到QQ群里交流吧:348944156,也欢迎关注本站微信公众号:centoscn
推荐内容