当前位置: > 故障解决 > 常用软件问题 >

解决centos运行程序找不到libstdc++.so.6错误方案

时间:2016-06-03 00:58来源:转载 作者:转载 举报 点击:

运行程序时遇到找不到libstdc++.so.6问题原因: 
系统是64bit,该库是32bit的,在64bit系统上安装32bit库

解决办法:

1. 查看哪个安装包包含该库:yum provides libstdc++.so.6

libstdc++-4.4.7-4.el6.i686

2. 安装 libstdc++-4.4.7-4.el6.i686

yum install  libstdc++-4.4.7-4.el6.i686

报错: 
–> Finished Dependency Resolution 
Error: Protected multilib versions: libstdc++-4.4.7-4.el6.i686 != libstdc++-4.4.7-3.el6.x86_64 
You could try using –skip-broken to work around the problem 
You could try running: rpm -Va –nofiles –nodigest 
…. 
解决办法: 
yum update libstdc++-4.4.7-3.el6.x86_64 
然后再执行yum install libstdc++-4.4.7-4.el6.i686

发表评论
为了和诣的生活,我关闭了评论页面,请大家到QQ群里交流吧:348944156,也欢迎关注本站微信公众号:centoscn
推荐内容