当前位置: 主页 > CentOS入门 > 系统配置 >

redhat7.1企业版使用centos 7的yum源

时间:2016-01-31 01:13来源:blog.csdn.net 作者:x6_9x 举报 点击:

众所周知 Red Hat 企业版服务器不注册的话是无法更新软件的。由于Redhat的yum在线更新是收费的,如果没有注册的话是不能使用的,即不能在线安装软件。在这种情况下,想使用Redhat系统,还想用yum源来在线安装软件,有没有办法?用cetos的yum来替换就好了

1.删除相关yum包

[root@localhost ~]# rpm -qa | grep yum
yum-rhn-plugin-2.0.1-5.el7.noarch
yum-3.4.3-132.el7.noarch
yum-utils-1.1.31-34.el7.noarch
yum-metadata-parser-1.1.4-10.el7.x86_64
yum-langpacks-0.4.2-4.el7.noarch
PackageKit-yum-1.0.7-5.el7.x86_64

#依次强制删除包
[root@localhost ~]# rpm -e yum-rhn-plugin-2.0.1-5.el7.noarch --nodeps
[root@localhost ~]# rpm -e yum-3.4.3-132.el7.noarch --nodeps
[root@localhost ~]# rpm -e yum-utils-1.1.31-34.el7.noarch           --nodeps
[root@localhost ~]# rpm -e yum-metadata-parser-1.1.4-10.el7.x86_64  --nodeps
[root@localhost ~]# rpm -e yum-langpacks-0.4.2-4.el7.noarch         --nodeps
警告:/etc/yum/pluginconf.d/langpacks.conf 已另存为 /etc/yum/pluginconf.d/langpacks.conf.rpmsave
[root@localhost ~]# rpm -e PackageKit-yum-1.0.7-5.el7.x86_64        --nodeps
#再次检测下,没了
[root@localhost ~]# rpm -qa | grep yum

#可以用xargs的方式 ,shell指令知道的多了,还是能省劲儿的
[root@localhost ~]# rpm -qa | grep yum |xargs rpm -e --nodeps 

2.用centos相关yum包替代被删除的包

可以用网易的更新源,这个地方是比较折腾的,就这几个包,折腾一个小时很正常,所以用rpm安装包是很苦逼的。

[root@localhost yum]# pwd
/opt/yum
#用wget 下载下来
wget http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-rhn-plugin-2.0.1-5.el7.noarch.rpm               
wget http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-3.4.3-132.el7.centos.0.1.noarch.rpm
wget http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-utils-1.1.31-34.el7.noarch.rpm
wget http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-metadata-parser-1.1.4-10.el7.x86_64.rpm 
wget http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-langpacks-0.4.2-4.el7.noarch.rpm
wget http://mirrors.163.com/centos/7/os/x86_64/Packages/PackageKit-yum-1.0.7-5.el7.centos.x86_64.rpm

#执行安装命令

rpm -ivh yum-rhn-plugin-2.0.1-5.el7.noarch.rpm               
rpm -ivh yum-3.4.3-132.el7.centos.0.1.noarch.rpm
rpm -ivh yum-utils-1.1.31-34.el7.noarch.rpm
rpm -ivh yum-metadata-parser-1.1.4-10.el7.x86_64.rpm 
rpm -ivh yum-langpacks-0.4.2-4.el7.noarch.rpm
rpm -ivh PackageKit-yum-1.0.7-5.el7.centos.x86_64.rpm

#已经下载全乎
[root@localhost yum]# ls
PackageKit-yum-1.0.7-5.el7.centos.x86_64.rpm  yum-langpacks-0.4.2-4.el7.noarch.rpm         yum-rhn-plugin-2.0.1-5.el7.noarch.rpm
yum-3.4.3-132.el7.centos.0.1.noarch.rpm       yum-metadata-parser-1.1.4-10.el7.x86_64.rpm  yum-utils-1.1.31-34.el7.noarch.rpm

#安装以下顺序安装
[root@localhost yum]# rpm -ivh yum-metadata-parser-1.1.4-10.el7.x86_64.rpm 
#提示yum-plugin-fastestmirror 被 yum-3.4.3-132.el7.centos.0.1.noarch 需要,下载,安装

[root@localhost yum]# wget http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-plugin-fastestmirror-1.1.31-34.el7.noarch.rpm
[root@localhost yum]# rpm -ivh yum-plugin-fastestmirror-1.1.31-34.el7.noarch.rpm
警告:yum-plugin-fastestmirror-1.1.31-34.el7.noarch.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
错误:依赖检测失败:
    yum >= 3.0 被 yum-plugin-fastestmirror-1.1.31-34.el7.noarch 需要

#单独安装还是有依赖需要,一块儿安装没事儿了

[root@localhost yum]# rpm -ivh yum-3.4.3-132.el7.centos.0.1.noarch.rpm yum-plugin-fastestmirror-1.1.31-34.el7.noarch.rpm
警告:yum-3.4.3-132.el7.centos.0.1.noarch.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
准备中...                          ################################# [100%]
正在升级/安装...
   1:yum-plugin-fastestmirror-1.1.31-3################################# [ 50%]
   2:yum-3.4.3-132.el7.centos.0.1     ################################# [100%]

#安装剩下的几个

[root@localhost yum]# rpm -ivh yum-rhn-plugin-2.0.1-5.el7.noarch.rpm               
警告:yum-rhn-plugin-2.0.1-5.el7.noarch.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
准备中...                          ################################# [100%]
正在升级/安装...
   1:yum-rhn-plugin-2.0.1-5.el7       ################################# [100%]
[root@localhost yum]# #rpm -ivh yum-3.4.3-132.el7.centos.0.1.noarch.rpm
[root@localhost yum]# rpm -ivh yum-utils-1.1.31-34.el7.noarch.rpm
警告:yum-utils-1.1.31-34.el7.noarch.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
准备中...                          ################################# [100%]
正在升级/安装...
   1:yum-utils-1.1.31-34.el7          ################################# [100%]
[root@localhost yum]# #rpm -ivh yum-metadata-parser-1.1.4-10.el7.x86_64.rpm 
[root@localhost yum]# rpm -ivh yum-langpacks-0.4.2-4.el7.noarch.rpm
警告:yum-langpacks-0.4.2-4.el7.noarch.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
准备中...                          ################################# [100%]
正在升级/安装...
   1:yum-langpacks-0.4.2-4.el7        ################################# [100%]
[root@localhost yum]# rpm -ivh PackageKit-yum-1.0.7-5.el7.centos.x86_64.rpm
警告:PackageKit-yum-1.0.7-5.el7.centos.x86_64.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
错误:依赖检测失败:
    PackageKit(x86-64) = 1.0.7-5.el7.centos 被 PackageKit-yum-1.0.7-5.el7.centos.x86_64 需要

#这个地方出现了一个包依赖问题,再次下载安装被依赖的包

[root@localhost yum]# wget http://mirrors.163.com/centos/7/os/x86_64/Packages/PackageKit-glib-1.0.7-5.el7.centos.x86_64.rpm
--2016-01-30 23:51:17--  http://mirrors.163.com/centos/7/os/x86_64/Packages/PackageKit-glib-1.0.7-5.el7.centos.x86_64.rpm
正在解析主机 mirrors.163.com (mirrors.163.com)... 123.58.173.185, 123.58.173.186
正在连接 mirrors.163.com (mirrors.163.com)|123.58.173.185|:80... 已连接。
已发出 HTTP 请求,正在等待回应... 200 OK
长度:127508 (125K) [application/x-redhat-package-manager]
正在保存至: “PackageKit-glib-1.0.7-5.el7.centos.x86_64.rpm”

100%[============================================================================================================>] 127,508      117KB/s 用时 1.1s   

2016-01-30 23:51:18 (117 KB/s) - 已保存 “PackageKit-glib-1.0.7-5.el7.centos.x86_64.rpm” [127508/127508])

[root@localhost yum]# rpm -ivh PackageKit-glib-1.0.7-5.el7.centos.x86_64.rpm
警告:PackageKit-glib-1.0.7-5.el7.centos.x86_64.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
准备中...                          ################################# [100%]

#安装被依赖的包,还是失败。

[root@localhost yum]# rpm -ivh PackageKit-1.0.7-5.el7.centos.x86_64.rpm
警告:PackageKit-1.0.7-5.el7.centos.x86_64.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
错误:依赖检测失败:
    PackageKit-backend 被 PackageKit-1.0.7-5.el7.centos.x86_64 需要
    PackageKit-glib(x86-64) = 1.0.7-5.el7.centos 被 PackageKit-1.0.7-5.el7.centos.x86_64 需要

#不管了,先加入参数--force前置安装再说


[root@localhost yum]# rpm -i --force --nodeps PackageKit-1.0.7-5.el7.centos.x86_64.rpm
警告:PackageKit-1.0.7-5.el7.centos.x86_64.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
[root@localhost yum]# rpm -ivh PackageKit-yum-1.0.7-5.el7.centos.x86_64.rpm
警告:PackageKit-yum-1.0.7-5.el7.centos.x86_64.rpm: 头V3 RSA/SHA256 Signature, 密钥 ID f4a80eb5: NOKEY
准备中...                          ################################# [100%]
    file /usr/lib64/packagekit-backend/libpk_backend_yum.so from install of PackageKit-yum-1.0.7-5.el7.centos.x86_64 conflicts with file from package PackageKit-1.0.7-5.el7.x86_64

终于折腾上了,还不是很放心,普及下rpm的几个知识:摘抄摘自这个网友的总结

前言:常用RPM的朋友们都知道,RPM简单易用,但是它的依赖关系是最头疼的!有时候比方说A包需要B包,B包需要C包,C包需要A包,好了。这就是最常见的死锁了(类似数据库有木有?)。这个时候有以下几种方式可以解决:  A、强制安装 —-暴力型  使用rpm -i –force –nodeps 强制安装。忽略依赖关系。这种方法你可以先装A包,再装B包,再装C包。这样还是有点隐患的,感觉不是很踏实(虽然其实目前没发现什么不好)。安装后使用成功的前提是:你要搞清楚依赖关系,并且把这些包都装好。好处是:不用管它们的具体依赖关系先后顺序。  B、一次性全装上— 一网打尽型  可以把依赖的几个包拷出来放在同一个文件夹里 然后 rpm -ivn *.rpm 这样也可以 前提也是一个都不能少。  C、 使用yum技术安装 –使用服务器方式  yum是一个服务器资源技术。通过在线下载服务器资源的方式。 缺点:太繁琐。要设置一堆的东西。优点:设置以后,很方便,需要的大多数资源都可以从服务器上找到。这点感觉很像maven2有木有?  参考:http://wenku.baidu.com/view/428c851352d380eb62946ded.html  D、使用redhat提供的解决方案,安装依赖关系库(强烈推荐)  例子:先安装rpmdb,之后使用  # rpm -ivh –aid samba*.rpm (一定要安装rpmdb后才可以用这种方式安装排除依赖关系)  该命令会自动把依赖关系中需要安装的包都安装上,包括:  cups-libs-1.1.17-13.3.6.rpm  samba-common-3.0.0-14.3E.i386.rpm  samba-3.0.0-14.3E.i386.rpm  samba-client-3.0.0-14.3E.i386.rpm  可以很简单地解决直接安装samba-3.0.0-14.3E.i386.rpm或者samba-client-3.0.0-14.3E.i386.rpm对samba-common-3.0.0-14.3E.i386.rpm 的依赖,而安装 sambacommon-3.0.0-14.3E.i386.rpm 出现对都libcups.so.2库文件的依赖,而且该库文件所在的rpm包无法很快确定  上述方法可以很快解决依赖关系

3.配置更改yum源,使用网易的CentOS镜像源

[root@localhost yum]# vim /etc/yum.repos.d/CentOS-Base.repo

#内容如下
[base]
name=CentOS-$releasever - Base - 163.com
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
baseurl=http://mirrors.163.com/centos/7/os/$basearch/
gpgcheck=1
gpgkey=http://mirrors.163.com/centos/RPM-GPG-KEY-CentOS-7

#released updates
[updates]
name=CentOS-$releasever - Updates - 163.com
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
baseurl=http://mirrors.163.com/centos/7/updates/$basearch/
gpgcheck=1
gpgkey=http://mirrors.163.com/centos/RPM-GPG-KEY-CentOS-7

#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras - 163.com
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras
baseurl=http://mirrors.163.com/centos/7/extras/$basearch/
gpgcheck=1
gpgkey=http://mirrors.163.com/centos/RPM-GPG-KEY-CentOS-7

#additional packages that extendfunctionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus - 163.com
baseurl=http://mirrors.163.com/centos/7/centosplus/$basearch/
gpgcheck=1
enabled=0
gpgkey=http://mirrors.163.com/centos/RPM-GPG-KEY-CentOS-7

4.检查并修正

#测试一下

[root@localhost yum]# yum install vim
已加载插件:fastestmirror, langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Loading mirror speeds from cached hostfile
软件包 2:vim-enhanced-7.4.160-1.el7.x86_64 已安装并且是最新版本
无须任何处理
[root@localhost yum]# yum update
已加载插件:fastestmirror, langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Loading mirror speeds from cached hostfile
正在解决依赖关系
--> 正在检查事务
---> 软件包 PackageKit-command-not-found.x86_64.0.1.0.7-5.el7 将被 升级
---> 软件包 PackageKit-command-not-found.x86_64.0.1.0.7-5.el7.centos 将被 更新
---> 软件包 PackageKit-glib.x86_64.0.1.0.7-5.el7 将被 升级
--> 正在处理依赖关系 PackageKit-glib(x86-64) = 1.0.7-5.el7,它被软件包 PackageKit-1.0.7-5.el7.x86_64 需要
---> 软件包 PackageKit-glib.x86_64.0.1.0.7-5.el7.centos 将被 更新
...此处省略N多字
---> 软件包 subscription-manager-gui.x86_64.0.1.15.9-15.el7 将被 升级
--> 正在处理依赖关系 subscription-manager-gui = 1.15.9-15.el7,它被软件包 subscription-manager-initial-setup-addon-1.15.9-15.el7.x86_64 需要
---> 软件包 subscription-manager-gui.x86_64.0.1.15.9-15.el7.centos.0.1 将被 更新
---> 软件包 system-config-date.noarch.0.1.10.6-2.el7 将被 升级
---> 软件包 system-config-date.noarch.0.1.10.6-2.el7.centos 将被 更新
---> 软件包 tuned.noarch.0.2.5.1-4.el7 将被 升级
---> 软件包 tuned.noarch.0.2.5.1-4.el7_2.1 将被 更新
--> 正在检查事务
---> 软件包 PackageKit-glib.x86_64.0.1.0.7-5.el7 将被 升级
--> 正在处理依赖关系 PackageKit-glib(x86-64) = 1.0.7-5.el7,它被软件包 PackageKit-1.0.7-5.el7.x86_64 需要
---> 软件包 abrt-retrace-client.x86_64.0.2.1.11-36.el7.centos 将被 安装
---> 软件包 libreport-centos.x86_64.0.2.1.11-32.el7.centos 将被 安装
---> 软件包 libreport-plugin-mantisbt.x86_64.0.2.1.11-32.el7.centos 将被 安装
---> 软件包 subscription-manager-gui.x86_64.0.1.15.9-15.el7 将被 升级
--> 正在处理依赖关系 subscription-manager-gui = 1.15.9-15.el7,它被软件包 subscription-manager-initial-setup-addon-1.15.9-15.el7.x86_64 需要
--> 解决依赖关系完成
错误:软件包:PackageKit-1.0.7-5.el7.x86_64 (@anaconda/7.2)
          需要:PackageKit-glib(x86-64) = 1.0.7-5.el7
          正在删除: PackageKit-glib-1.0.7-5.el7.x86_64 (@anaconda/7.2)
              PackageKit-glib(x86-64) = 1.0.7-5.el7
          更新,由: PackageKit-glib-1.0.7-5.el7.centos.x86_64 (base)
              PackageKit-glib(x86-64) = 1.0.7-5.el7.centos
错误:软件包:subscription-manager-initial-setup-addon-1.15.9-15.el7.x86_64 (@anaconda/7.2)
          需要:subscription-manager-gui = 1.15.9-15.el7
          正在删除: subscription-manager-gui-1.15.9-15.el7.x86_64 (@anaconda/7.2)
              subscription-manager-gui = 1.15.9-15.el7
          更新,由: subscription-manager-gui-1.15.9-15.el7.centos.0.1.x86_64 (base)
              subscription-manager-gui = 1.15.9-15.el7.centos.0.1
 您可以尝试添加 --skip-broken 选项来解决该问题
** 发现 4 个已存在的 RPM 数据库问题, 'yum check' 输出如下:
PackageKit-1.0.7-5.el7.x86_64 有缺少的需求 PackageKit-backend
PackageKit-1.0.7-5.el7.centos.x86_64 是 PackageKit-1.0.7-5.el7.x86_64 的副本
PackageKit-1.0.7-5.el7.centos.x86_64 有缺少的需求 PackageKit-backend
PackageKit-1.0.7-5.el7.centos.x86_64 有缺少的需求 PackageKit-glib(x86-64) = ('0', '1.0.7', '5.el7.centos')

#解决步骤2遗留的问题,将有问题的包删除重新安装,以自动解决依赖问题,这个可以直接在步骤2中尝试

[root@localhost yum]# rpm -e PackageKit-1.0.7-5.el7.centos.x86_64 --nodeps
[root@localhost yum]# yum install PackageKit-1.0.7-5.el7.centos.x86_64.rpm
已加载插件:fastestmirror, langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
正在检查 PackageKit-1.0.7-5.el7.centos.x86_64.rpm: PackageKit-1.0.7-5.el7.centos.x86_64
PackageKit-1.0.7-5.el7.centos.x86_64.rpm 将作为 PackageKit-1.0.7-5.el7.x86_64 的更新
正在解决依赖关系
--> 正在检查事务
---> 软件包 PackageKit.x86_64.0.1.0.7-5.el7 将被 升级
---> 软件包 PackageKit.x86_64.0.1.0.7-5.el7.centos 将被 更新
--> 正在处理依赖关系 PackageKit-glib(x86-64) = 1.0.7-5.el7.centos,它被软件包 PackageKit-1.0.7-5.el7.centos.x86_64 需要
Loading mirror speeds from cached hostfile
--> 正在处理依赖关系 PackageKit-backend,它被软件包 PackageKit-1.0.7-5.el7.centos.x86_64 需要
--> 正在检查事务
---> 软件包 PackageKit-glib.x86_64.0.1.0.7-5.el7 将被 升级
--> 正在处理依赖关系 PackageKit-glib(x86-64) = 1.0.7-5.el7,它被软件包 PackageKit-command-not-found-1.0.7-5.el7.x86_64 需要
--> 正在处理依赖关系 PackageKit-glib(x86-64) = 1.0.7-5.el7,它被软件包 PackageKit-gtk3-module-1.0.7-5.el7.x86_64 需要
--> 正在处理依赖关系 PackageKit-glib(x86-64) = 1.0.7-5.el7,它被软件包 PackageKit-gstreamer-plugin-1.0.7-5.el7.x86_64 需要
---> 软件包 PackageKit-glib.x86_64.0.1.0.7-5.el7.centos 将被 更新
---> 软件包 PackageKit-yum.x86_64.0.1.0.7-5.el7.centos 将被 安装
--> 正在检查事务
---> 软件包 PackageKit-command-not-found.x86_64.0.1.0.7-5.el7 将被 升级
---> 软件包 PackageKit-command-not-found.x86_64.0.1.0.7-5.el7.centos 将被 更新
---> 软件包 PackageKit-gstreamer-plugin.x86_64.0.1.0.7-5.el7 将被 升级
---> 软件包 PackageKit-gstreamer-plugin.x86_64.0.1.0.7-5.el7.centos 将被 更新
---> 软件包 PackageKit-gtk3-module.x86_64.0.1.0.7-5.el7 将被 升级
---> 软件包 PackageKit-gtk3-module.x86_64.0.1.0.7-5.el7.centos 将被 更新
--> 解决依赖关系完成

依赖关系解决

======================================================================================================================================================
 Package                                  架构               版本                             源                                                 大小
======================================================================================================================================================
正在更新:
 PackageKit                               x86_64             1.0.7-5.el7.centos               /PackageKit-1.0.7-5.el7.centos.x86_64             2.6 M
为依赖而安装:
 PackageKit-yum                           x86_64             1.0.7-5.el7.centos               base                                               76 k
为依赖而更新:
 PackageKit-command-not-found             x86_64             1.0.7-5.el7.centos               base                                               21 k
 PackageKit-glib                          x86_64             1.0.7-5.el7.centos               base                                              125 k
 PackageKit-gstreamer-plugin              x86_64             1.0.7-5.el7.centos               base                                               13 k
 PackageKit-gtk3-module                   x86_64             1.0.7-5.el7.centos               base                                               13 k

事务概要
======================================================================================================================================================
安装           ( 1 依赖软件包)
升级  1 软件包 (+4 依赖软件包)

总计:2.8 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
警告:RPM 数据库已被非 yum 程序修改。
  正在更新    : PackageKit-glib-1.0.7-5.el7.centos.x86_64                                                                                        1/11 
  正在安装    : PackageKit-yum-1.0.7-5.el7.centos.x86_64                                                                                         2/11 
  正在更新    : PackageKit-1.0.7-5.el7.centos.x86_64                                                                                             3/11 
  正在更新    : PackageKit-command-not-found-1.0.7-5.el7.centos.x86_64                                                                           4/11 
  正在更新    : PackageKit-gtk3-module-1.0.7-5.el7.centos.x86_64                                                                                 5/11 
  正在更新    : PackageKit-gstreamer-plugin-1.0.7-5.el7.centos.x86_64                                                                            6/11 
  清理        : PackageKit-gstreamer-plugin-1.0.7-5.el7.x86_64                                                                                   7/11 
  清理        : PackageKit-gtk3-module-1.0.7-5.el7.x86_64                                                                                        8/11 
  清理        : PackageKit-command-not-found-1.0.7-5.el7.x86_64                                                                                  9/11 
  清理        : PackageKit-1.0.7-5.el7.x86_64                                                                                                   10/11 
  清理        : PackageKit-glib-1.0.7-5.el7.x86_64                                                                                              11/11 
  验证中      : PackageKit-glib-1.0.7-5.el7.centos.x86_64                                                                                        1/11 
  验证中      : PackageKit-yum-1.0.7-5.el7.centos.x86_64                                                                                         2/11 
  验证中      : PackageKit-1.0.7-5.el7.centos.x86_64                                                                                             3/11 
  验证中      : PackageKit-command-not-found-1.0.7-5.el7.centos.x86_64                                                                           4/11 
  验证中      : PackageKit-gtk3-module-1.0.7-5.el7.centos.x86_64                                                                                 5/11 
  验证中      : PackageKit-gstreamer-plugin-1.0.7-5.el7.centos.x86_64                                                                            6/11 
  验证中      : PackageKit-gstreamer-plugin-1.0.7-5.el7.x86_64                                                                                   7/11 
  验证中      : PackageKit-glib-1.0.7-5.el7.x86_64                                                                                               8/11 
  验证中      : PackageKit-command-not-found-1.0.7-5.el7.x86_64                                                                                  9/11 
  验证中      : PackageKit-gtk3-module-1.0.7-5.el7.x86_64                                                                                       10/11 
  验证中      : PackageKit-1.0.7-5.el7.x86_64                                                                                                   11/11 

作为依赖被安装:
  PackageKit-yum.x86_64 0:1.0.7-5.el7.centos                                                                                                          

更新完毕:
  PackageKit.x86_64 0:1.0.7-5.el7.centos                                                                                                              

作为依赖被升级:
  PackageKit-command-not-found.x86_64 0:1.0.7-5.el7.centos                     PackageKit-glib.x86_64 0:1.0.7-5.el7.centos                           
  PackageKit-gstreamer-plugin.x86_64 0:1.0.7-5.el7.centos                      PackageKit-gtk3-module.x86_64 0:1.0.7-5.el7.centos                    

完毕!


#再用 yum update 检查下 ,已经没有错误

至此终于折腾完毕!

------分隔线----------------------------
发表评论
为了和诣的生活,我关闭了评论页面,请大家到QQ群里交流吧:348944156,也欢迎关注本站微信公众号:centoscn